System Requirements

If you are unsure that your computer meets the minimum system requirements, click on the "Analyze My System" button below. We will test your system and notify you of the results.

Below are the minimum software and browser requirements to use online training with Safety Unlimited, Inc. Even though users may meet the minimum requirements, we still recommend they update their software and browser, along with its plug-ins, to the latest released version. We have included a link to each of the appropriate software websites, where, if necessary, users can download the latest version of the programs they require. Also, we recommend all users have high-speed internet in order to have good access to our online courses.

It should be noted that while the vast majority of our users do not have any issues meeting the minimum system requirements, occasionally we do have users who have trouble accessing our online training because of local settings or other factors. Usually, these issues are the result of slower internet connections or out-dated computer hardware.

To use online training, users should have a basic knowledge of computers. This should include, but is not limited to, the ability to use a mouse, which involves knowing the difference between left-click and right-click; the ability to open and close documents and web pages; and the ability to navigate a website and web pages. Those with no computer experience at all may have trouble using our online training and, for their own benefit, may want to enroll in a basic computer training class before using any of our online courses. Advanced computer users will be able to use our eLearning system to its full capacity.

NOTE: A few courses have slightly different systems requirements, which are listed on the course's outline page.

Browsers

Firefox

Mozilla Firefox

Minimum requirement: Firefox 2 and above
http://www.mozilla.com/en-US/
Safari

Apple Safari

Minimum requirement: Safari 3 and above
http://www.apple.com/safari/download/
Chrome

Google Chrome

Minimum requirement: Chrome 40 and above
https://www.google.com/chrome/browser/
Explorer

Microsoft Internet Explorer

Minimum requirement: Internet Explorer 8 and above
* OSHA 10 and 30 hour courses do not support Internet Explorer 11
http://www.microsoft.com/windows/downloads/ie/getitnow.mspx

Adobe Reader/Acrobat

Adobe Acrobat
Minimum requirement: 7.0 and above
http://get.adobe.com/reader/

Adobe Flash Player

Flash Player
Minimum requirement: 7.0 and above
* OSHA 10 and 30 hour courses require version 10 and above.
http://get.adobe.com/flashplayer/

Cookies

Students must enable cookies on their browsers. They also must have their internet security set to medium or allow www.safetyunlimited.com access with their security settings.

Firewall Settings

Firewall settings must allow streaming media from this website through Port 80.

Pop-up Window Blockers

Pop-up window blockers must be disabled while using this website.

Please Contact Us if you have any questions about online training in general or Safety Unlimited's online training in particular.